2019 WordPress 必备插件保举

推荐下 WordPress 必备的插件,插件的使用主要从 SEO、安全、营销、UI设计、访问数据分析几个方面去考虑,当然并不是插件安装越多越好,过多的插件会拖慢网站加载速度,只在满足需求的前提下安装必要的一些插件。

此外在安装插件启用之前最好先备份下网站数据,很可能因为版本不兼容的原因导致数据库读写异常,这样整个网站就挂了,以防万一,每次安装或者更新插件之前先备份下网站数据。

做网站SEO必不可少的插件, 可以设置谷歌、Bing、百度、Yandex 的验证码,可以检测文章可读性和SEO的好坏等等,但要记得把分类和TAG的索引关闭,避免内部链接的内容重复。

如果是要编辑robot.txt,入口在工具=文件编辑器里面,记得在一个网站没有建好之前要robots.txt设置成:

压缩HTML,合并CSS,提高网站加载速度,可以直接在插件里面设置CDN加速等等,缓存的设置按照下面截图照搬就行。

帮助自动压缩网站的图片,避免图片过大拖慢网站的加载速度,配合TinyPNG(一起使用更好,每次上传图片之前最好先经过TinyPNG压缩一遍之后再上传,不得不说目前在图片的压缩方面,TinyPNG无疑是最好的。

虽然Yoast SEO插件自带网站地图的设置,但是如果要提高配置的可控性,使用Google XML Sitemaps会好点,在提交到Google Search Console收录之后出现一些链接地址无法索引的情况,后面就把HTML网站地图功能关闭掉就好了。

如果是使用Genesis Framework主题 ,Genesis Simple Edits是必不可少的插件,如果手动修改Genesis Framework主题代出异常,甚至会导致WordPress账户后台无法登陆,之前尝试过在主题类中增加几行代码修改样式,后面导致整个服务异常,无法登陆,所以,最好不要手动修改Genesis Framework主题的代码,通过插件去修改保险点。

如果是要实现上面的底部栏效果,可以在插件Footer Output输入框中贴上以下代码来实现,xxxxxxx替换成自己网站的名称。

使用Genesis Framework主题之后发现评论的字体偏大了,通过Super Customizer插件可以修改文章和评论默认的字体大小,还有主题的各种自定义样式修改。

网站从HTTP切换成HTTPS必备的插件,切换的过程中涉及到301重定向,URL参数的修改等等,如果手动修改难免出错,这个在阿里云免费SSL证书申请和WordPress服务器配置文章中已经有提及过。

博客中的联系页面功能可以使用上面两个插件配合实现。 WPForms Lite插件用来自定义联系人表格、注册表格等,WP Mail SMTP 插件用来设置接收邮件的参数,比如设置QQ邮箱作为博客的接收邮箱,可以参考这篇文章:WordPress如何发送邮件?

做境外Affiliate必备插件,EasyaAzon一个很重要的功能是可以根据地理位置设置不同的跳转链接,比如在澳大利亚可以跳转到澳大利亚区域的亚马逊店铺,加拿大可以跳转到加拿大区域的亚马逊店铺。比如网站默认的地理位置设置在美国,如果加拿大或者澳大利亚区域的用户点击链接跳转到的是美国区域的店铺,很容易就放弃购买,这样会损失一部分转化率。

10Beasts的博主曾使用geniuslink (来本地化购买链接,后面出现一个Bug,导致返利成了geniuslink的收益,后面他就弃用了。

编辑插件推荐在WordPress自带的编辑工具上,安装TinyMCE Advanced插件,WordPress自带的插件功能太简陋了,覆盖安装第三方插件多多少少会有点问题。TinyMCE Advanced插件可以提供字体大小设置功能,可以在插件设置页面拖动在编辑栏上要显示的功能模块。

一定不要安装Kindeditor For WordPress插件,这个插件很久没更新了,而且是覆盖安装,最大的一个问题是在上下滑动编辑区域的时候无法悬浮编辑工具栏,这样要编辑设置文本属性的时候每次都要滑动到文章头部设置,非常麻烦。而且插入媒体内容的时候每次都是把内容加到文章末尾,不是在输入光标的位置插入内容,每次都要从文章末尾剪切黏贴到插入的位置。

文章中的出站链接一般都要设置成nofollow属性,避免权重传递。其他的Nofollow插件会有这样那样的问题,试了几个插件只有这个没有Bug。

为了避免每次单独登陆Google Analytics的麻烦,可以集成Google Analytics到WordPress操作面板中,但似乎在阿里云服务器上的防火墙会屏蔽Google Analytics链接的访问,境外网站的使用没问题。

这边不建议使用WP Statistics插件,虽然用这个插件可以看到很多详细的访问数据,但在集成之后发现网站页面的加载速度明显变长了,而且会产生大量的Log记录。

如果WordPress版本被服务器自动升级到5.0,之后就容易出现很多WordPress插件不兼容的情况,这就需要对WordPress版本进行降级,使用这个插件输入要降级或升级的版本号操作即可。使用完之后可以关闭此插件,需要的时候再激活。

有的时候会出现升级WordPress版本或者插件自更新到高版本出现插件不兼容的异常,这个时候就需要回退安装旧版本的插件。首先进入WordPress网站主页,比如要下载Jetpack旧版本插件,先进入Jetpack插件主页,在插件页面右侧有一个Advanced View入口。

未经允许不得转载:主机宝贝 » 2019 WordPress 必备插件保举

评论 抢沙发

评论前必须登录!